ViewVC logotype

Revision 1405

Jump to revision: Previous Next
Author: okoeroo
Date: Wed Jan 20 13:42:07 2010 UTC (12 years, 5 months ago)
Changed paths: 1
Log Message:
Fixed the threadsafe_getuid_from_name() to be safer, easier to read, contain a 1k buffer by default, clean itself up properly, set errno at the end of the function to the proper state (bypassing the free() and other functions) and having sufficient comments in the code for understandability.

Changed paths

Path Details
Directorytrunk/grid-mw-security/cgul/unixprivs/unixpriv.c modified , text changed

ViewVC Help
Powered by ViewVC 1.1.28